{"_id":"5693bcb273f48f0d0075c917","version":{"_id":"5633ec007e9e880d00af1a56","project":"5633ebff7e9e880d00af1a53","__v":16,"createdAt":"2015-10-30T22:15:28.105Z","releaseDate":"2015-10-30T22:15:28.105Z","categories":["5633ec007e9e880d00af1a57","5633f072737ea01700ea329d","5637a37d0704070d00f06cf4","5637cf4e7ca5de0d00286aeb","564503082c74cf1900da48b4","564503cb7f1fff210078e70a","567af26cb56bac0d0019d87d","567afeb8802b2b17005ddea0","567aff47802b2b17005ddea1","567b0005802b2b17005ddea3","568adfffcbd4ca0d00aebf7e","56ba80078cf7c9210009673e","574d127f6f075519007da3d0","574fde60aef76a0e00840927","57a22ba6cd51b22d00f623a0","5a062c15a66ae1001a3f5b09"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":true,"codename":"","version_clean":"1.0.0","version":"1.0"},"category":{"_id":"574d127f6f075519007da3d0","project":"5633ebff7e9e880d00af1a53","__v":0,"version":"5633ec007e9e880d00af1a56","sync":{"url":"","isSync":false},"reference":false,"createdAt":"2016-05-31T04:26:39.925Z","from_sync":false,"order":4,"slug":"versions","title":"Versions"},"project":"5633ebff7e9e880d00af1a53","user":"5633ec9b35355017003ca3f2","parentDoc":null,"__v":46,"updates":["5696a2c6cb14e11700f8a9f3"],"next":{"pages":[],"description":""},"createdAt":"2016-01-11T14:31:14.305Z","link_external":false,"link_url":"","githubsync":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":4,"body":"Elasticsearch has a menagerie of available plugins, including support for custom ones. We often get asked through our support channels whether we support a particular plugin and whether the user can install their own. Here you'll find all the info you could ever want to know about plugins on Bonsai Elasticsearch.\n\n## Do you support plugin X?\n\nWe support all of the most commonly used Elasticsearch plugins, with some caveats. Plugins like Shield and Marvel require a license for commercial purposes, and we only offer support for those on Enterprise class clusters. We also don't generally deploy unofficial plugins to the Shared level plans for stability and security reasons.\n\nThese are the plugins we currently deploy by default for all clusters:\n\n* [Mapper Attachments](https://github.com/elastic/elasticsearch-mapper-attachments)\n* [ICU Analyzer](https://github.com/elastic/elasticsearch-analysis-icu)\n* [Kuromoji Analyzer](https://github.com/elastic/elasticsearch-analysis-kuromoji)\n* [Phonetic analyzer](https://github.com/elastic/elasticsearch-analysis-phonetic)\n* [Smart Chinese Analyzer](https://github.com/elastic/elasticsearch-analysis-smartcn)\n* [Stempel Analyzer](https://github.com/elastic/elasticsearch-analysis-stempel)\n\n2.x clusters also have these plugins:\n\n* [Delete-by-Query](https://www.elastic.co/guide/en/elasticsearch/plugins/2.0/delete-by-query-usage.html)\n\nThe mapper and analysis plugins are interesting to note, as they provide some really cool ways to optimize your search.\n\n## Can I install my own plugins on Bonsai?\n\nThe answer depends on what kind of cluster you're on. If you're on an Enterprise plan, **absolutely.** These clusters are custom designed for your use case, and we can work with you on deploying whatever plugins you need.\n\nIf your cluster is on one of our shared clusters, then it's not possible to install a non-standard plugin. At Bonsai we'd love to be able to give you everything you want for your cluster, but we need to be opinionated about our shared cluster architecture to ensure security and performance for all other users.\n\n## More questions?\n\nStill have questions or concerns that weren't addressed here? Shoot us an [email](mailto:support:::at:::bonsai.io) and let us know.!","excerpt":"","slug":"plugins","type":"basic","title":"Supported Plugins"}
Elasticsearch has a menagerie of available plugins, including support for custom ones. We often get asked through our support channels whether we support a particular plugin and whether the user can install their own. Here you'll find all the info you could ever want to know about plugins on Bonsai Elasticsearch. ## Do you support plugin X? We support all of the most commonly used Elasticsearch plugins, with some caveats. Plugins like Shield and Marvel require a license for commercial purposes, and we only offer support for those on Enterprise class clusters. We also don't generally deploy unofficial plugins to the Shared level plans for stability and security reasons. These are the plugins we currently deploy by default for all clusters: * [Mapper Attachments](https://github.com/elastic/elasticsearch-mapper-attachments) * [ICU Analyzer](https://github.com/elastic/elasticsearch-analysis-icu) * [Kuromoji Analyzer](https://github.com/elastic/elasticsearch-analysis-kuromoji) * [Phonetic analyzer](https://github.com/elastic/elasticsearch-analysis-phonetic) * [Smart Chinese Analyzer](https://github.com/elastic/elasticsearch-analysis-smartcn) * [Stempel Analyzer](https://github.com/elastic/elasticsearch-analysis-stempel) 2.x clusters also have these plugins: * [Delete-by-Query](https://www.elastic.co/guide/en/elasticsearch/plugins/2.0/delete-by-query-usage.html) The mapper and analysis plugins are interesting to note, as they provide some really cool ways to optimize your search. ## Can I install my own plugins on Bonsai? The answer depends on what kind of cluster you're on. If you're on an Enterprise plan, **absolutely.** These clusters are custom designed for your use case, and we can work with you on deploying whatever plugins you need. If your cluster is on one of our shared clusters, then it's not possible to install a non-standard plugin. At Bonsai we'd love to be able to give you everything you want for your cluster, but we need to be opinionated about our shared cluster architecture to ensure security and performance for all other users. ## More questions? Still have questions or concerns that weren't addressed here? Shoot us an [email](mailto:support@bonsai.io) and let us know.!